SchoolDude
Incident Report for SDIRC
Resolved
Issue remains on Schooldude. Closing as it does not impact users that do not use GIS
Posted Oct 19, 2022 - 11:36 EDT
Investigating
Automated Message: SchoolDude has posted an incident message on their status page. If you are experiencing issues with services from this provider, please check the SchoolDude Status Page for more details.
--
Posted Aug 18, 2022 - 11:31 EDT
This incident affected: Third Party (Third-party - Other).