Pelican Island Elementary School Network Outage
Incident Report for SDIRC
Resolved
District IT has confirmed network connectivity has been restored for Pelican Island Elementary.
Thank you for your patience and understanding.
Posted Jan 17, 2023 - 16:15 EST
Investigating
There is currently a network outage at Pelican Island Elementary school. Our partners are currently investigating the outage and will provide the school district with additional updates during the repair process. At this time, there is no estimate for time for repair.
Posted Jan 11, 2023 - 08:44 EST
This incident affected: District Network (Wired Network, Wireless Network).