SchoolDude
Incident Report for SDIRC
Resolved
Automated Message: SchoolDude has marked the incident as resolved. For additional details regarding this incident, please review the Dude Solutions Status Incident History page.
Posted May 30, 2023 - 10:46 EDT
Investigating
Automated Message: SchoolDude has posted an incident message on their status page. If you are experiencing issues with services from this provider, please check the SchoolDude Status Page for more details.
--
Posted May 30, 2023 - 09:23 EDT